ログインしていません。

#1 2017-01-27 09:05:15

yamato
ゲストユーザー

CUPSが自動起動しない。

LXDE環境で、CUPSをインストールしました。
起動・有効化を行ったのですが、再起動してもCUPSが起動していません。
[yamato@Arch2017 ~]$ systemctl status org.cups.cupsd.service
● org.cups.cupsd.service - CUPS Scheduler
   Loaded: loaded (/usr/lib/systemd/system/org.cups.cupsd.service; enabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:cupsd(8)
[yamato@Arch2017 ~]$ systemctl is-enabled org.cups.cupsd.service
enabled
[yamato@Arch2017 ~]$

vendor preset: disabled これが気になるのですが・・。
どこを調べれば良いのか御教授願います。

#2 2017-01-27 20:15:17

kusakata
管理者
登録日: 2014-12-19
投稿: 37

Re: CUPSが自動起動しない。

「vendor preset: disabled」はディストリビューションのデフォルト設定で有効化されているかどうかなので関係ないと思います。
org.cups.cupsd.service にはデフォルトで以下の行が含まれており、プリンターが接続されていないと起動しないようになっています。

WantedBy=printer.target

ネットワークプリンターを使う場合は avahi-daemon.service と cups-browsed.service を有効にすれば org.cups.cupsd.service も自動で立ち上げられます。
ネットワークプリンターを使っていない場合で、プリンターがコンピュータに接続されていなくても CUPS を起動したいときは(無駄ですが)以下のコマンドを実行してください。

# systemctl add-wants multi-user.target org.cups.cupsd.service

オフライン

#3 2017-01-27 23:15:27

yamato
ゲストユーザー

Re: CUPSが自動起動しない。

早速の回答をありがとうございます。書き忘れていましたが、当方はネットワークプリンタ使用です。
avahi-daemon.service
cups-browsed.service
指示通りにこの二つを有効にした所、org.cups.cupsd.serviceが自動で立ち上がるようになりました。
的確な指示をありがとうございました。

クィック投稿

メッセージを書いて送信してください。
ボット判定

本当の人間が送信しようとしていることを確認します。

Board footer