ログインしていません。

#1 2015-11-17 00:23:00

pure
メンバー
登録日: 2015-11-16
投稿: 23
ウェブサイト

startxfce4のコマンドでXfce Desktopの画面が起動しない。

こんにちは。
VMware Workstation 11の仮想環境に、Arch LinuxのXfce4環境のインストールをして、仮想マシンを作製しました。
startxfce4あるいはstartxのコマンドを入力すると、グラフィック画面が起動しない状況です。
改善の方法等はあるのでしょうか。
よろしくお願いいたします。
「エラーメッセージ」
failed to add fb -22
(EE)
Fatal server error:
(EE) AddScreen/ScreenInit failed for driver 0
(EE)
(EE)
Please consult the The X Org Foundation support
at http://wiki.x.org for help.
(EE) Please also check the log file at “/home/pure/.local/share/xorg/Xorg.0.log” for additional information.
(EE)
Xorg: xf86Helper.c:1929: xf86ScrnToScreen: Assertion ‘pScrn->scrnIndex < screenInfo.num Screens’ failed.
xinit: unable to connect to X server: Connection refused
xinit: server error

オフライン

#2 2015-11-17 01:42:17

nomuken
メンバー
登録日: 2015-10-07
投稿: 6
ウェブサイト

Re: startxfce4のコマンドでXfce Desktopの画面が起動しない。

こんにちは,初めまして.

エラー拝見させていただきました.
vmware向けのグラフィックドライバはインストールなさられていますでしょうか?
https://wiki.archlinuxjp.org/index.php/ … D.E5.AE.9A

オフライン

#3 2015-11-17 14:12:12

pure
メンバー
登録日: 2015-11-16
投稿: 23
ウェブサイト

Re: startxfce4のコマンドでXfce Desktopの画面が起動しない。

こんにちは。
お返事をいただきまして、ありがとうございます。
vmware向けのグラフィックドライバをインストールしましたところ、Xfce4のデスクトップ画面が起動しました。
ありがとうございます。
ここでまた、新たな問題が生じています。
マウスが全く動作をしない状況です。

マウスの問題に、以下の記述がありました。

VMware は自動的にゲーム用にマウスを最適化します。
問題が発生した場合、最適化を無効にするのを推奨します。
Edit > Preferences > Input > Optimize mouse for games: Never

これは、具体的にはどのような操作手順で行うのでしょうか。

また、その他の改善の方法等について何かありましたら、ご教示をお願いいたします。
よろしくお願いいたします。

オフライン

#4 2015-11-17 17:15:05

nomuken
メンバー
登録日: 2015-10-07
投稿: 6
ウェブサイト

Re: startxfce4のコマンドでXfce Desktopの画面が起動しない。

先ほど投稿いたしました記事の中に書かれていたと思うですが,以下のパッケージはインストールされていますでしょうか?
xf86-input-vmmouse, xf86-video-vmware, mesa-dri

オフライン

#5 2015-11-17 19:30:41

pure
メンバー
登録日: 2015-11-16
投稿: 23
ウェブサイト

Re: startxfce4のコマンドでXfce Desktopの画面が起動しない。

そちらの三つのパッケージはインストールをいたしました。
よろしくお願いいたします。

オフライン

#6 2015-11-17 20:45:11

nomuken
メンバー
登録日: 2015-10-07
投稿: 6
ウェブサイト

Re: startxfce4のコマンドでXfce Desktopの画面が起動しない。

となりますと,マウスの設定をひとまず試していただいたほうが良いかと存じます.
Wikiの手順は少々分かりづらいように思えましたので補足いたしますと,「VMware Workstation 11の設定を」以下のようにしてみてください.
・Edit メニューから Preferences を開く
・Input タブを選択し,ウィンドウの中程にある Optimize mouse for games の設定値を Never にする

自分の所有しているVMware Workstationは12 proなので細部が違うかもしれませんが以下の赤線の部分をNeverにしてみてください.
https://spica.bz/blog/content/images/2015/11/Screenshot-from-2015-11-17-20-30-29-1.png

オフライン

#7 2015-11-17 22:28:35

pure
メンバー
登録日: 2015-11-16
投稿: 23
ウェブサイト

Re: startxfce4のコマンドでXfce Desktopの画面が起動しない。

分かりやすいお返事をいただきまして、ありがとうございます。
マウスの設定を変更して起動いたしましたが、マウスは動作をしませんでした。
何か、致命的な原因があるのでしょうか。
よろしくお願いいたします。

オフライン

#8 2015-11-17 23:29:12

kusakata
管理者
登録日: 2014-12-19
投稿: 37

Re: startxfce4のコマンドでXfce Desktopの画面が起動しない。

こんにちは。
ログファイルの /home/pure/.local/share/xorg/Xorg.0.log に何か参考になる情報は出力されていませんか?
もしパーミッションに問題があるようでしたら本家 wiki のページに載っている vmtoolsd.service の有効化と /etc/X11/Xwrapper.config の設定を試してみて下さい。
日本語 wiki の方はしばらく翻訳を更新してなくて新しい情報が載っていませんでした、すいません。

オフライン

#9 2015-11-17 23:48:35

nomuken
メンバー
登録日: 2015-10-07
投稿: 6
ウェブサイト

Re: startxfce4のコマンドでXfce Desktopの画面が起動しない。

kusakataさん,こんにちははじめまして.(と,管理いつもありがとうございます)
一応,補足ですが確認するべきログファイルの位置は「~/.local/share/xorg/Xorg.0.log」という方が一般的かもしれません.
もちろん,ユーザ名がそれなら問題はないですが……

英語の方の確認完全に忘れてました,情報ありがとうございます.

編集者 nomuken (2015-11-17 23:49:21)

オフライン

#10 2015-11-18 10:30:59

pure
メンバー
登録日: 2015-11-16
投稿: 23
ウェブサイト

Re: startxfce4のコマンドでXfce Desktopの画面が起動しない。

こんにちは。
お返事をいただきまして、本当にありがとうございます。
cat –n /home/pure/.local/share/xorg/Xorg.0.log
cat –n ~/.local/share/xorg/Xorg.0.log
で調べてみました。
どちらも415行で同じ内容でしたが、参考になる情報等はありませんでした。
また、nano /etc/X11/Xwrapper.confで設定を記述しましたが、何故か設定を保存できませんでした。
この度は、色々とご教示をいただきましてお世話になりました。
この案件は、これで終了といたしたいと考えています。
ありがとうございました。

オフライン

クィック投稿

メッセージを書いて送信してください。
ボット判定

本当の人間が送信しようとしていることを確認します。

Board footer